summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..afb7fdfc6c83
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+VERSION = 0.1.0
+RELEASE = 1
+
+release: PKGBUILD .SRCINFO
+ updpkgsums
+ rm v$(VERSION).tar.gz
+ git add .SRCINFO Makefile PKGBUILD
+ git commit -m "Release v$(VERSION)"
+ #git push
+
+PKGBUILD:
+ sed -i 's/^pkgver=.*/pkgver=$(VERSION)/g' PKGBUILD
+ sed -i 's/^pkgrel=.*/pkgrel=$(RELEASE)/g' PKGBUILD
+
+.SRCINFO:
+ makepkg --printsrcinfo > .SRCINFO
+
+.PHONY: release