summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..c664e257a66e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,25 @@
+# Helper make file
+BINARY:=gk6x
+
+all: uninstall install clean
+
+.PHONY: clean
+clean:
+ @echo "Cleaning build files..."
+ @rm -rf *.pkg.tar.xz *.zst *.zip pkg src
+ @echo "Done."
+
+.PHONY: build
+build:
+ @updpkgsums ./PKGBUILD
+ @makepkg -fp ./PKGBUILD --noconfirm
+ @makepkg --printsrcinfo > .SRCINFO
+
+.PHONY: install
+install:
+ @updpkgsums ./PKGBUILD
+ @makepkg -Ccip ./PKGBUILD --noconfirm
+
+.PHONY: uninstall
+uninstall:
+ @sudo pacman -R $(BINARY) --noconfirm