summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f224580dd9d7..3a8706e0c5d2 100644
--- a/Makefile
+++ b/Makefile
@@ -5,3 +5,12 @@ get-checksum:
.PHONY: update
update: get-checksum
makepkg --printsrcinfo > .SRCINFO
+
+# you may want to do a setup previous to use this target
+# follow https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot#Classic_way
+.PHONY: build
+build:
+ @echo "updating ${CHROOT}/root chroot environment..."
+ @arch-nspawn $CHROOT/root pacman -Syu
+ @echo "building package in isolation"
+ makechrootpkg -c -r $CHROOT