summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..97498ec29c6e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+CC=gcc
+PREFIX=/usr
+BINDIR=$(PREFIX)/bin
+DESTDIR=
+BIN=gtkrc-reload
+CFLAGS=`pkg-config --cflags --libs gdk-2.0`
+
+all: $(BIN)
+
+$(BIN):
+ @$(CC) $(BIN).c $(CFLAGS) -o $(BIN)
+
+install:
+ mkdir -p $(DESTDIR)$(BINDIR)
+ install -Dm755 $(BIN) $(DESTDIR)$(BINDIR)
+
+clean:
+ @rm -f $(BIN)