summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index aecfcbdd05a7..ac1aec31d998 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,12 @@
obj-m := ia32_aout.o
-KDIR := /usr/lib/modules/$(shell uname -r)/build
+KDIR := /usr/lib/modules/$(KVERSION)/build
PWD := $(shell pwd)
all:
$(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+.PHONY: clean
+
+clean:
+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) clean
+