summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..bdfd498f482e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+.PHONY: all build push clean
+
+all: .SRCINFO
+ git add PKGBUILD .SRCINFO
+
+.SRCINFO: PKGBUILD
+ namcap PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+build:
+ makepkg -f
+ namcap *.pkg.tar.zst
+
+push: build .SRCINFO
+ git add PKGBUILD .SRCINFO
+ git commit
+ git push
+
+clean:
+ rm -f *.pkg.tar.zst
+ rm -fr pkg src