summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 3ba30d08257b..0269644cd2d6 100644
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,28 @@
-MAKEFLAGS += --warn-undefined-variables
+MAKEFLAGS += --no-builtin-rules --no-builtin-variables --warn-undefined-variables
+unexport MAKEFLAGS
.DEFAULT_GOAL := all
.DELETE_ON_ERROR:
.SUFFIXES:
SHELL := bash
-.SHELLFLAGS := -e -o pipefail -c
+.SHELLFLAGS := -eu -o pipefail -c
+
+.PHONY: DO
+DO:
escape = $(subst ','\'',$(1))
+define noexpand
+ifeq ($$(origin $(1)),environment)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),environment override)
+ $(1) := $$(value $(1))
+endif
+ifeq ($$(origin $(1)),command line)
+ override $(1) := $$(value $(1))
+endif
+endef
+
PKG_NAME := linux-status
this_dir := $(dir $(realpath $(firstword $(MAKEFILE_LIST))))