summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rwxr-xr-xMakefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100755
index 000000000000..54d37f3f892e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+all:
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+ rm -f *.zip
+ rm -f *.zst
+
+clean:
+ rm -f *.tgz
+ rm -f *.zst
+
+test:
+ make clean
+ makepkg
+ namcap PKGBUILD
+ namcap *.pkg.tar.zst
+
+mount:
+ docker run -it -v $(shell dirname $(realpath $(firstword $(MAKEFILE_LIST))))/:/vol -w /vol \
+ -v /tmp/.X11-unix:/tmp/.X11-unix:ro \
+ -v $(HOME)/.config/pulse/cookie:/home/user/.config/pulse/cookie:ro \
+ $(shell docker build -qf .docker/Dockerfile-testarch .) \ No newline at end of file