summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 73a15b457f73..59ec6d06624b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,5 @@
+ROOT_DIR:=$(shell dirname $(realpath $(lastword $(MAKEFILE_LIST))))
+
all: .SRCINFO verify
.SRCINFO: PKGBUILD
@@ -14,5 +16,8 @@ verify:
makepkg -f
namcap PKGBUILD
namcap *.pkg.tar.xz
+ @echo "precheck succeeded. Run the final check with:"
+ @echo ""
+ @echo "sudo rkt --net=host --dns=host --insecure-options=image run docker://base/archlinux --interactive=true --exec /pkg/test_in_rkt.sh --volume pkg,kind=host,source=$(ROOT_DIR) --mount volume=pkg,target=/pkg"
.PHONY: verify clean all