summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..c4d24c4120ab
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+PY = rofi-twitch
+ICON = $(PY).png
+DESKTOP = $(PY).desktop
+
+pkg: .SRCINFO
+ makepkg --check --noconfirm -sf
+
+.SRCINFO: PKGBUILD
+ makepkg --check --printsrcinfo > $@
+
+PKGBUILD: format pngopt $(DESKTOP)
+ updpkgsums
+
+format: $(PY)
+ yapf -i $<
+
+pngopt: $(ICON)
+ optipng $<
+
+.PHONY: format pngopt
+.PRECIOUS: $(PY) $(ICON) $(DESKTOP) PKGBUILD