summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..9e0756c3ef01
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+VERSION := $(shell grep "pkgver=" PKGBUILD | cut -d"=" -f2)
+RELEASE := $(shell grep "pkgrel=" PKGBUILD | cut -d"=" -f2)
+
+default:
+
+update:
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+ git add PKGBUILD .SRCINFO
+ git commit -m "release $(VERSION)-$(RELEASE)"
+ git tag "$(VERSION)-$(RELEASE)"
+
+.PHONY: default