aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ed35d69cd3db..e8c281709708 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@
help:
@grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
-build:clear ## Build pakage
+build:clear recup ## Build pakage
makepkg -s
clear: ## Clear files
@@ -10,7 +10,6 @@ clear: ## Clear files
rm -rf ./src
rm -f ./shadowbeta.deb
rm -f ./shadow-beta-*.pkg.tar
- rm -f ./*.pl
rm -f ./*~
install:build ## Install package with pacman
@@ -19,5 +18,10 @@ install:build ## Install package with pacman
pkgsum: ## update pkgsum with updpkgsums
updpkgsums
+recup: ## Get git files
+ wget -O INSTALL https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/Arch/AUR/INSTALL
+ wget -O wrapper.pl https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/wrapper.pl
+ wget -O report.pl https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/AppImage/report.pl
+
srcinfo: ## génération .SRCINFO
makepkg --printsrcinfo > .SRCINFO