summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..664060f6d125
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+.PHONY: all check gensign release
+
+all:
+ makepkg -f
+
+check:
+ namcap PKGBUILD
+ namcap *.zst
+
+geninteg:
+ makepkg --geninteg
+
+release:
+ makepkg --printsrcinfo > .SRCINFO
+ git add PKGBUILD .SRCINFO