summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 21 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ac7f6ecf6f71..768a1f8c629e 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,28 @@
+# SHELL:=/bin/bash
+.DEFAULT_GOAL:=update
-VERSION ?= $(shell stty -echo; read -p "Latest release: " pwd; stty echo; echo $$pwd)
+export ROOTDIR:=$(shell dirname $(realpath $(lastword $(MAKEFILE_LIST))))
+# ## Install all dependencies
+# # Usage:
+# # make deps
+# deps: deps-python
+# #/ activates virenv and installs deps
+# deps-python:
+# @cd "$(ROOTDIR)"
+# @if [ ! -d $(VIRTUAL_ENV)/bin ] ; \
+# then \
+# virtualenv --python=python3 "$(VIRTUAL_ENV)" ;\
+# fi
+# @. $(VIRTUAL_ENV)/bin/activate ; \
+# $(VIRTUAL_ENV)/bin/pip3 install -r $(ROOTDIR)/requirements.txt -q
+
+## Update (automatic)
update:
- ./update.sh $(VERSION)
+ nvchecker source.ini
+ ./update.sh
clean:
rm -rf src pkg *.tar.xz *.gz *.pkg.tar
+ rm -rf $(VIRTUAL_ENV)