summarylogtreecommitdiffstats
path: root/PKGBUILD.common
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD.common')
-rw-r--r--PKGBUILD.common8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD.common b/PKGBUILD.common
index 02c164115574..ab04645732f9 100644
--- a/PKGBUILD.common
+++ b/PKGBUILD.common
@@ -3,14 +3,14 @@
pkgver=16.2.6
_pkgver=16.2.6
-pkgrel=1
+pkgrel=2
arch=(i686 x86_64)
groups=('bareos')
pkgdesc="Bareos - Backup Archiving REcovery Open Sourced"
url="http://www.bareos.org"
license=('AGPL3')
makedepends=('sqlite3' 'libmariadbclient' 'postgresql-libs' 'lzo' 'acl' 'libcap' 'python2' 'python')
-optdepends=('openssl: network encryption between daemons')
+optdepends=('openssl-1.0: network encryption between daemons')
_instdir="${startdir}/install"
_pkgsrc="${startdir}/src/bareos"
@@ -65,6 +65,10 @@ prepare() {
}
build() {
+ # bug: openssl 1.0 isue
+ export CFLAGS="${CFLAGS} -L /usr/include/openssl-1.0"
+ export LIBS="${LIBS} -I /usr/include/openssl-1.0"
+
pushd "${_pkgsrc}" &> /dev/null
QMAKE="/usr/bin/qmake-qt4" DISTNAME="debian" ./configure $_configure_args
make DESTDIR="$_instdir" install