summarylogtreecommitdiffstats
path: root/PKGBUILD.common
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD.common')
-rw-r--r--PKGBUILD.common4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD.common b/PKGBUILD.common
index b7a0c27801f9..c0ff4a05da98 100644
--- a/PKGBUILD.common
+++ b/PKGBUILD.common
@@ -63,6 +63,10 @@ prepare() {
}
build() {
+ # bareos 15.2 doesn't work with gcc 6.1.1 and newer with optimizations
+ export CFLAGS="${CFLAGS/O2/O0}"
+ export CXXFLAGS="${CXXFLAGS/O2/O0}"
+
pushd "${_pkgsrc}" &> /dev/null
QMAKE="/usr/bin/qmake-qt4" DISTNAME="debian" ./configure $_configure_args
make DESTDIR="$_instdir" install