summarylogtreecommitdiffstats
path: root/PKGBUILD.in
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD.in')
-rw-r--r--PKGBUILD.in16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 5b4f39d6bff5..d786adc52613 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -7,12 +7,12 @@ pkgdesc='Electronic schematic and printed circuit board (PCB) design tools'
arch=('x86_64')
url='http://kicad-pcb.org/'
license=('GPL')
-depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
-makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig')
-optdepends=(
- 'kicad-library: for footprints and symbols'
- 'kicad-library-3d: for 3d models of components'
+depends=(
+ 'wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade'
+ 'python-wxpython' 'kicad-library-nightly'
)
+makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig')
+optdepends=('kicad-library-3d-nightly: for 3d models of components')
source=(
'git+https://gitlab.com/kicad/code/kicad.git'#commit=@KICAD_HASH@
'git+https://gitlab.com/kicad/code/kicad-i18n.git'#commit=@I18N_HASH@
@@ -23,12 +23,6 @@ sha256sums=(
'fce26af6b9c181a99197bfc9bc6c778561ad55a375480f4d0d73bb34078b5d18'
)
-pkgver()
-{
- cd "$srcdir/kicad"
- git describe --tags | sed -e 's/-/_/g'
-}
-
build()
{
cd "$srcdir/kicad"