summarylogtreecommitdiffstats
path: root/PKGBUILD.old
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD.old')
-rw-r--r--PKGBUILD.old46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD.old b/PKGBUILD.old
new file mode 100644
index 000000000000..2e80fed992be
--- /dev/null
+++ b/PKGBUILD.old
@@ -0,0 +1,46 @@
+# Maintainer: Jeremy Pope <jpope at jpope dot org> PGP-Key: E00B4261
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: noonov <noonov@gmail.com>
+# Contributor: wtchappell <wtchappell@gmail.com>
+
+pkgname=awesome-git
+pkgver=3.5.2.215.gf0ab2ae
+pkgrel=1
+pkgdesc='Highly configurable framework window manager'
+arch=('i686' 'x86_64')
+url='http://awesome.naquadah.org/'
+license=('GPL2')
+depends=('cairo' 'dbus' 'gdk-pixbuf2' 'imlib2' 'libxdg-basedir' 'lua' 'lua-lgi'
+ 'pango' 'startup-notification' 'xcb-util-cursor' 'xcb-util-keysyms'
+ 'xcb-util-wm' 'xorg-xmessage')
+makedepends=('asciidoc' 'cmake' 'docbook-xsl' 'doxygen' 'imagemagick' 'xmlto'
+ 'git')
+optdepends=('rlwrap: readline support for awesome-client'
+ 'dex: autostart your desktop files'
+ 'vicious: widgets for the Awesome window manager')
+provides=('notification-daemon' 'awesome')
+conflicts=('awesome')
+backup=('etc/xdg/awesome/rc.lua')
+source=($pkgname::git+http://github.com/awesomeWM/awesome.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ cmake \
+ -DCMAKE_BUILD_TYPE=RELEASE \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSYSCONFDIR=/etc \
+ -DLUA_LIBRARY=/usr/lib/liblua.so.5.2
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+ install -Dm644 awesome.desktop "$pkgdir"/usr/share/xsessions/awesome.desktop
+}