summarylogtreecommitdiffstats
path: root/PKGBUILD.testing
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD.testing')
-rw-r--r--PKGBUILD.testing126
1 files changed, 6 insertions, 120 deletions
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index dd2d984cb5ca..041eacefd4c0 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -1,12 +1,12 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
pkgname=proton
-_srctag=8.0-2c
+_srctag=8.0-3c
_commit=
-pkgver=8.0.2.3 # pkgver=${_srctag//-/.}
+pkgver=8.0.3.3 # pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.1
-pkgrel=9
+pkgrel=1
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
@@ -75,36 +75,12 @@ optdepends=(
gst-plugins-base-libs lib32-gst-plugins-base-libs
vulkan-icd-loader lib32-vulkan-icd-loader
libgphoto2
- dosbox
)
makedepends=(${makedepends[@]} ${depends[@]})
install=${pkgname}.install
source=(
proton::git+https://github.com/ValveSoftware/Proton.git#tag=proton-${_srctag}
- wine-valve::git+https://github.com/ValveSoftware/wine.git
- dxvk::git+https://github.com/doitsujin/dxvk.git
- openvr::git+https://github.com/ValveSoftware/openvr.git
- liberation-fonts::git+https://github.com/liberationfonts/liberation-fonts.git
- gstreamer::git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git
- gst-plugins-base::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-base.git
- gst-plugins-good::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-good.git
- gst-orc::git+https://gitlab.freedesktop.org/gstreamer/orc.git
- vkd3d-proton::git+https://github.com/HansKristian-Work/vkd3d-proton.git
- OpenXR-SDK::git+https://github.com/KhronosGroup/OpenXR-SDK.git
- dxvk-nvapi::git+https://github.com/jp7677/dxvk-nvapi.git
- vkd3d-valve::git+https://github.com/ValveSoftware/vkd3d.git
- Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
- SPIRV-Headers::git+https://github.com/KhronosGroup/SPIRV-Headers.git
- Vulkan-Loader::git+https://github.com/KhronosGroup/Vulkan-Loader.git
- glslang::git+https://github.com/KhronosGroup/glslang.git
- gst-libav::git+https://gitlab.freedesktop.org/gstreamer/gst-libav.git
- ffmpeg::git+https://git.ffmpeg.org/ffmpeg.git
- dav1d::git+https://code.videolan.org/videolan/dav1d.git
- gst-plugins-rs::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs.git
- dxil-spirv::git+https://github.com/HansKristian-Work/dxil-spirv.git
- graphene::git+https://github.com/ebassi/graphene.git
- libdisplay-info-dxvk::git+https://gitlab.freedesktop.org/JoshuaAshton/libdisplay-info.git
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
0001-AUR-Pkgbuild-changes.patch
@@ -165,68 +141,10 @@ prepare() {
mv "$srcdir"/wine-gecko-${_geckover}-x86{,_64}.tar.xz contrib/
mv "$srcdir"/wine-mono-${_monover}-x86.tar.xz contrib/
- _submodules=(
- wine-valve::wine
- dxvk
- openvr
- liberation-fonts::fonts/liberation-fonts
- gstreamer
- gst-plugins-base
- gst-plugins-good
- gst-orc
- vkd3d-proton
- OpenXR-SDK
- dxvk-nvapi
- vkd3d-valve::vkd3d
- Vulkan-Headers
- SPIRV-Headers
- Vulkan-Loader
- glslang
- gst-libav
- ffmpeg
- dav1d
- gst-plugins-rs
- graphene
- )
+ git -c protocol.file.allow=always submodule update --init --filter=tree:0 --recursive
- for submodule in "${_submodules[@]}"; do
- git submodule init "${submodule#*::}"
- git submodule set-url "${submodule#*::}" "$srcdir"/"${submodule%::*}"
- git -c protocol.file.allow=always submodule update "${submodule#*::}"
- done
-
- pushd dxvk
- git submodule init include/{vulkan,spirv}
- git submodule set-url include/vulkan "$srcdir/Vulkan-Headers"
- git submodule set-url include/spirv "$srcdir/SPIRV-Headers"
- git -c protocol.file.allow=always submodule update include/{vulkan,spirv}
-
- git submodule init subprojects/libdisplay-info
- git submodule set-url subprojects/libdisplay-info "$srcdir/libdisplay-info-dxvk"
- git -c protocol.file.allow=always submodule update subprojects/libdisplay-info
- popd
-
- pushd vkd3d-proton
- for submodule in subprojects/{dxil-spirv,Vulkan-Headers,SPIRV-Headers}; do
- git submodule init "${submodule}"
- git submodule set-url "${submodule}" "$srcdir"/"${submodule#*/}"
- git -c protocol.file.allow=always submodule update "${submodule}"
- done
- pushd subprojects/dxil-spirv
- git submodule init third_party/spirv-headers
- git submodule set-url third_party/spirv-headers "$srcdir"/SPIRV-Headers
- git -c protocol.file.allow=always submodule update third_party/spirv-headers
- popd
- popd
-
- pushd dxvk-nvapi
- git submodule init external/Vulkan-Headers
- git submodule set-url external/Vulkan-Headers "$srcdir"/Vulkan-Headers
- git -c protocol.file.allow=always submodule update external/Vulkan-Headers
- popd
-
- for submodule in gst-plugins-rs media-converter; do
- pushd $submodule
+ for rustlib in gst-plugins-rs media-converter; do
+ pushd $rustlib
export RUSTUP_TOOLCHAIN=stable
export CARGO_HOME="${SRCDEST}"/proton-cargo
cargo fetch --locked --target "i686-unknown-linux-gnu"
@@ -238,15 +156,6 @@ prepare() {
patch -p1 -i "$srcdir"/0002-AUR-Do-not-update-cargo-crates.patch
patch -p1 -i "$srcdir"/0004-AUR-Copy-DLL-dependencies-of-32bit-libvkd3d-dlls-int.patch
patch -p1 -i "$srcdir"/fix_hwnd_changes_meaning.patch
-
- # Remove repos from srcdir to save space
- for submodule in "${_submodules[@]}"; do
- rm -rf "$srcdir"/"${submodule%::*}"
- done
- rm -rf "$srcdir"/dxil-spirv
- rm -rf "$srcdir"/Vulkan-Headers
- rm -rf "$srcdir"/SPIRV-Headers
- rm -rf "$srcdir"/libdisplay-info-dxvk
}
build() {
@@ -343,29 +252,6 @@ package() {
}
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'08d318f3dd6440a8a777cf044ccab039b0d9c8809991d2180eb3c9f903135db3'
'0beac419c20ee2e68a1227b6e3fa8d59fec0274ed5e82d0da38613184716ef75'
'1286afc67b0a329f5e2d98d9e803ca5906a841ad5486e9b3b1fefa1124b15622'