summarylogtreecommitdiffstats
path: root/PKGBUILD.testing
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD.testing')
-rw-r--r--PKGBUILD.testing7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 33f72d0c6f36..b7556b168ecc 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -6,7 +6,7 @@ _commit=610dead69d75fe548b4349dadb3ab04e7e466095
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=8.0.0
-pkgrel=6
+pkgrel=7
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -309,6 +309,9 @@ build() {
package() {
cd build
+ # Delete the intermediate build directories to free space (mostly for my github actions)
+ rm -rf dst-* obj-* src-* pfx-*
+
local _compatdir="$pkgdir/usr/share/steam/compatibilitytools.d"
mkdir -p "$_compatdir/${pkgname}"
rsync --delete -arx dist/* "$_compatdir/${pkgname}"
@@ -320,6 +323,8 @@ package() {
# a runtime dependency.
cp /usr/i686-w64-mingw32/bin/{libgcc_s_dw2-1.dll,libwinpthread-1.dll} \
"$_compatdir/${pkgname}"/files/lib/vkd3d/
+ cp /usr/x86_64-w64-mingw32/bin/{libgcc_s_seh-1.dll,libwinpthread-1.dll} \
+ "$_compatdir/${pkgname}"/files/lib64/vkd3d/
mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
mv "$_compatdir/${pkgname}"/LICENSE{,.OFL} \