summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3877d0e4a917
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: yubimusubi
+pkgname=('3dsconv-git')
+provides=('3dsconv')
+conflicts=('3dsconv')
+pkgver=r71.8a82606
+pkgrel=1
+pkgdesc='Tool to convert Nintendo 3DS CTR Cart Image files (CCI, ".3ds") to the CTR Importable Archive format (CIA).'
+arch=('any')
+url="https://github.com/ihaveamac/3dsconv"
+license=('MIT')
+depends=('python2')
+makedepends=('git' 'tar')
+options=('!strip')
+
+source=(
+ "$pkgname::git+https://github.com/ihaveamac/3dsconv.git"
+)
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -d "$pkgdir/usr/bin/"
+ install "3dsconv.py" "$pkgdir/usr/bin/3dsconv"
+}