summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b3dd6292354..02c06ce6239e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Contributor: Jakub Bittner, vlastikcz
+# Contributor: Jakub Bittner, vlastikcz, mezcal, Mario Hros
pkgname=602xmlfiller
pkgver=4.52.0.3_13.0725
-pkgrel=1
-pkgdesc="Application for filling in and submitting smart forms (ZFO) or work with form applications on desktop PC environment"
-url="http://www.602.eu/form-filler"
+pkgrel=2
+pkgdesc="Application for filling in and submitting smart forms (ZFO) or work with form applications on desktop PC environment. Without bundled Wine."
+url="https://www.602.cz/o-nas/ke-stazeni/aktualni-produkty/form-filler/"
arch=('i686' 'x86_64')
license=('custom')
-depends=('nss')
+depends=('nss' 'wine')
if [[ $CARCH == 'i686' ]]; then
source=("$pkgname-$pkgver.deb::http://www.602.cz/download/602xml/RPM/kub11/Software602_Form_Filler.deb")
@@ -15,7 +15,10 @@ elif [[ $CARCH == 'x86_64' ]]; then
source=("$pkgname_x64-$pkgver.deb::http://www.602.cz/download/602xml/RPM/kub11_x64/Software602_Form_Filler.deb")
md5sums=('a13159d7a74b9dffe436beeccaa0dc2b')
fi
-
+
+source+=('filler.sh')
+md5sums+=('de5790c5d990f43119fd1282fc1545d6')
+
build() {
tar -xf data.tar.gz
@@ -23,4 +26,7 @@ build() {
package() {
cp -dr --no-preserve=ownership usr "$pkgdir/"
+ rm -rf "$pkgdir/usr/lib/602filler/"{bin,lib,share} "$pkgdir/usr/lib/602filler/.wine/lib"
+ install -Dm755 "$srcdir/filler.sh" "$pkgdir/usr/bin/filler.sh"
}
+