summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99421ffd2f80..bddfca85b241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,11 +17,17 @@ sha256sums=('d9dc32efba7e74f788fcc4f212a43216fc37cf5f23f4c2339664d473353aedf6')
build() {
cd $_pkgname-$pkgver
+if [ n != "$RUN_PREPARE" ]; then
+ if [ 1 = "$ccache" ]; then
+ export CC=${CC:-ccache ${_target}-gcc}
+ export CXX=${CXX:-ccache ${_target}-g++}
+ fi
unset CFLAGS CXXFLAGS
./configure --prefix=/usr/${_target} \
--host=${_target} \
--disable-static
make
+fi
}
strip() {