summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b974efd853b9..3ed83acdc374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,19 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=aarchup-git
-pkgver=1.8.3.r1.g598d1e5
+pkgver=2.1.7
pkgrel=1
pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
-url="https://github.com/aericson/aarchup"
+url="https://github.com/inglor/aarchup"
arch=('i686' 'x86_64')
license=('GPL')
depends=('libnotify' 'gtk2')
-makedepends=('git')
-source=("git+https://github.com/stefanhusmann/aarchup.git")
+makedepends=('git' 'cmake' 'meson' 'ninja')
+source=("git+https://gitlab.com/artafinde/aarchup.git")
md5sums=('SKIP')
-backup=('usr/lib/systemd/system/aarchup.timer')
conflicts=('aarchup')
provides=('aarchup')
optdepends=('auracle: AUR support(--aur)')
-install=aarchup.install
pkgver() {
cd ${pkgname%-git}
@@ -26,13 +24,12 @@ pkgver() {
}
build() {
- cd ${pkgname%-git}/src
- autoconf
- ./configure --prefix=/usr
- make
+ cd ${pkgname%-git}
+ meson --prefix=/usr --buildtype=plain . build
+ meson compile -C build
}
package() {
- cd ${pkgname%-git}/src
- make DESTDIR="$pkgdir/" install
+ cd ${pkgname%-git}
+ DESTDIR="$pkgdir/" ninja install -C build
}