summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1916c135a70d..00d02e2d76ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Maintainer: Xyne
pkgname=abinit
-pkgver=8.10.3
-pkgrel=2
+pkgver=9.2.1
+pkgrel=1
pkgdesc="Full-featured atomic-scale first-principles simulation software."
arch=('i686' 'x86_64')
url="https://www.abinit.org/"
license=('GPLv3')
-depends=('lapack' 'blas' 'openmpi')
+depends=('lapack' 'blas' 'openmpi' 'netcdf' 'netcdf-fortran' 'hdf5' 'libxc')
makedepends=('gcc8-fortran' 'perl')
source=(
"https://www.abinit.org/sites/default/files/packages/$pkgname-$pkgver.tar.gz"
@@ -16,13 +16,22 @@ source=(
build() {
cd -- "$srcdir/$pkgname-$pkgver"
- ./configure FC=gfortran-8 CC=cc-8 --prefix=/usr #--disable-all-plugins
+ mkdir -p build && cd build
+ ../configure \
+ FC=gfortran-8 \
+ CC=cc-8 \
+ --with-libxc='yes' \
+ --with-hdf5='yes' \
+ --with-netcdf='yes' \
+ --with-netcdf-fortran='yes' \
+ --prefix=/usr \
+ #--disable-all-plugins
make -j $(($(nproc) + 1))
}
package() {
- cd -- "$srcdir/$pkgname-$pkgver"
+ cd -- "$srcdir/$pkgname-$pkgver/build"
make DESTDIR="$pkgdir" install
}
-sha512sums=('6ae0e1f2e220d51b1f1a6122b81b12664b5148955710945371279ca28a092fd30278c62765b324f85004467c925f1048c20ecec3bb6c38f9f114d0182b647420')
+sha512sums=('31405d3c29526ef4022b5299b94eb729ef0996717e391c865ec1e53dd9c45c688c4c70fbbdbb72c036665cbd153eff141b2eeb5b5bc455e0a24fac350e7cca5d')