summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 334724f6f71b..f99dee06d788 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
# Maintainer: Jonian Guveli <https://github.com/jonian/>
pkgname=acestream-launcher
pkgver=2.1.0
-pkgrel=2
-pkgdesc="Acestream Launcher allows you to open Acestream links with a Media Player of your choice"
+pkgrel=3
+pkgdesc="Open AceStream links with a Media Player of your choice"
arch=("any")
url="https://github.com/jonian/acestream-launcher"
-license=("GPL")
+license=("GPL-3.0-only")
depends=("python" "python-acestream")
-optdepends=("mpv" "libnotify" "acestream-engine")
-makedepends=("python-setuptools")
+optdepends=(
+ "acestream-engine"
+ "libnotify: support for desktop notifications"
+ "mpv: default media player"
+)
+makedepends=(
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
+)
provides=("${pkgname}")
-conflicts=("${pkgname}-git")
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-md5sums=("aee038c11ceebcd5c36dec9fd9286f02")
+sha256sums=('ab3a9a8c88d95674c9159df02625b9dd4f8827cfe1b9322dfce9dfd19f3c725c')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}