summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57e3211a63e8..38ad2204d743 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="act-git"
_pkgname="act"
-pkgver=0.2.5
+pkgver=0.2.14.r0.g7d443c6
pkgrel=1
pkgdesc='Run your GitHub Actions locally'
arch=('x86_64')
@@ -16,6 +16,11 @@ makedepends=('go' 'git')
source=("act::git+https://github.com/nektos/act.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
export GOPATH="$srcdir"/gopath
cd "$srcdir/$_pkgname"