summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 16 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da69ba310b84..6c9b26b0982e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,39 @@
# Maintainer: Jose Riha <jose1711 gmail com>
# Contributor: Bazon <bazonbloch@arcor.de>
+
pkgname=activtools
-pkgver=5.10.15
+pkgver=5.16.7
pkgrel=1
pkgdesc="Includes activmanager, activcalibrate, activremote and activmonitor.
You must install activtools if you want to use ActivInspire with Promethean
hardware. You do not need activtools if you just want to run ActivInspire
Personal Edition."
arch=('i686' 'x86_64')
-url="http://activsoftware.co.uk/linux/repos/ubuntu/dists/precise/Release"
+url="https://support.prometheanworld.com/product/activdriver"
license=('unknown')
-if [ "$CARCH" = "i686" ]; then
- _arch='i386'
- _md5sum='748d75db8520778572dbada9f004e547'
- depends=('qt4' 'libudev.so.0')
-else
- _arch='amd64'
- _md5sum='c7e54948cc6d38c71a8e70e123d7c200'
- depends=('qt4' 'libudev.so.0' 'lib32-libudev.so.0' 'lib32-glibc<2.21')
-fi
+depends=('qt4')
+
optdepends=('activinspire: activboard presentation')
-source=(http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activtools/activtools_$pkgver-1~ubuntu~1204_$_arch.deb)
-md5sums=( $_md5sum )
+source_x86_64=(http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/non-oss/a/activtools/activtools_$pkgver-0~Ubuntu~1604_amd64.deb activinspire-restart.desktop)
+source_i686=(http://activsoftware.co.uk/linux/repos/driver/ubuntu/pool/non-oss/a/activtools/activtools_$pkgver-0~Ubuntu~1604_i386.deb activinspire-restart.desktop)
+
+md5sums_x86_64=('4583a2b4280e267e0ab72bf5c026ac65' 'fe9981eca6b2e3299f3a7ed908a6b83d')
+md5sums_i686=('08ac88e9ceb17f2f4290231f5c2380f5' 'fe9981eca6b2e3299f3a7ed908a6b83d')
package() {
- # extract the archive
- bsdtar -xf data.tar.gz -C "$pkgdir"
+ # extract archive
+ bsdtar -C "$pkgdir" -xf data.tar.xz
# move out of the local directory to match arch standards
mv "$pkgdir"/usr/local/* "$pkgdir"/usr/
rmdir "$pkgdir"/usr/local
- #activmgr works only when started after board is attached, so no autostart.
- #Delete the follwing line if you want an autostart of activmgr
+ # activmgr works only when started after board is attached, so no autostart.
+ # Delete the following line if you want an autostart of activmgr
cd "$pkgdir"
rm -r etc
- #activcalibrate needs libactivboardex.so.1 instead of libactivboardex.so.1.0
- #(and needs to be killed after last calibration point with Alt+F4)
- #(if you know how to fix: please tell!)
- cd "$pkgdir"/usr/lib
- ln -s libactivboardex.so.1.0 libactivboardex.so.1
- if [ "$CARCH" = "x86_64" ]; then
- cd "$pkgdir"/usr/lib32 libactivboardex.so.1.0
- ln -s libactivboardex.so.1.0 libactivboardex.so.1
- fi
+ sed -i '/LD_LIBRARY_PATH/d' usr/bin/activmgr.sh
echo " "
echo "when activtools is installed, activinspire needs to be killed before it can restart"
@@ -53,22 +42,8 @@ package() {
cd "$pkgdir"/usr/bin
touch inspire-restart
chmod a+x inspire-restart
- echo "#! /bin/bash" > inspire-restart
+ echo "#!/bin/bash" > inspire-restart
echo "killall inspire Inspire ; inspire \"\$1\"" >> "$pkgdir"/usr/bin/inspire-restart
-
- cd "$pkgdir"/usr/share/applications/
- echo "[Desktop Entry]" > activinspire-restart.desktop
- echo "Name=ActivInspire (restart)" >> activinspire-restart.desktop
- echo "Comment=Promethean ActivInspire - restart needed when using activtools" >> activinspire-restart.desktop
- echo "Exec=/usr/bin/inspire-restart" >> activinspire-restart.desktop
- echo "Icon=/usr/share/icons/hicolor/512x512/apps/inspire.ico" >> activinspire-restart.desktop
- echo "Terminal=false" >> activinspire-restart.desktop
- echo "Encoding=UTF-8" >> activinspire-restart.desktop
- echo "Type=Application" >> activinspire-restart.desktop
- echo "Categories=Education;Promethean;Applications;" >> activinspire-restart.desktop
- echo "MimeType=application/x-asstudio;" >> activinspire-restart.desktop
- echo "StartupNotify=false" >> activinspire-restart.desktop
-
echo " "
echo "activcalibrate has to be closed by Alt+F4 or get killed after the last calibration-point."
echo " "