summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 15 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aaa7204dcb93..75b2da0392c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
-# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Kenneth Endfinger <kaendfinger@gmail.com>
pkgname=addinclude
-pkgver=1.0.1
-pkgrel=4
+pkgver=1.2.0
+pkgrel=1
pkgdesc='Add include statements to header and sourcefiles, for C and C++'
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
-url='https://addinclude.roboticoverlords.org/'
-license=('GPL2')
-makedepends=('go')
-source=("https://addinclude.roboticoverlords.org/$pkgname-$pkgver.tar.xz"{,.asc})
-validpgpkeys=('962855F072C7A01846405864FCF3C8CB5CF9C8D4')
-sha512sums=('bb73427f85abd747104e2b24c19da3e1daf31ee0af2f1da5c268ef47cd8657c2e06d6a0611c153afeae1492752926f3765521643ee41a6337a7fe40ca55336aa'
- 'SKIP')
+arch=(x86_64)
+url='https://github.com/xyproto/addinclude'
+license=(GPL2)
+makedepends=(go)
+source=("https://github.com/xyproto/addinclude/releases/download/v1.2.0/addinclude-1.2.0.tar.xz")
+b2sums=('0ae646d99549fa6e3e9d76aea1c4b3046215339129caaf5c7d21a2629bbe841fd5fc91cdbffcd72ba717d3b325ed880e5173947781beca8ea55f7937423a2a8e')
build() {
- cd "${pkgname}-${pkgver}"
-
- go build -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
+ cd $pkgname-$pkgver
+ go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags \"${LDFLAGS}\""
}
package() {
- cd "${pkgname}-${pkgver}"
-
- install -Dm755 "${pkgname}-${pkgver}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
}
-
-# vim: ts=2 sw=2 et: