summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dba5bf42b52..7735b22e58d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,18 @@
pkgname=adobe-source-han-mono-classic-fonts
pkgver=1.002
+_commit=5888cdabc66f48976e7a9605aae91ed39cea27f8
pkgrel=5
pkgdesc='Adobe Source Han Mono - Classic Style Chinese Character'
arch=('any')
-url='https://github.com/redchenjs/source-han-mono-classic/'
-license=('OFL')
-source=(
- 'git+https://github.com/redchenjs/source-han-mono-classic.git'
-)
-md5sums=(
- 'SKIP'
-)
+url="https://github.com/redchenjs/source-han-mono-classic"
+license=('custom:OFL')
+source=("https://github.com/redchenjs/source-han-mono-classic/archive/$_commit/source-han-mono-classic-$_commit.tar.gz")
+sha512sums=('438ed2426479979cd908734b4f7c5c56870cbbcec4365c6ecc9cb86b79a14a37ebacb1df7050fdbb8726a0c268b24fc0e4d60f6d56e9cccb9bd71c77f749abe9')
package() {
- install -dm 755 ${pkgdir}/usr/share/fonts/adobe-source-han-sans/
- install -Dm 644 ${srcdir}/source-han-mono-classic/*.otf \
- ${pkgdir}/usr/share/fonts/adobe-source-han-sans/
+ cd source-han-mono-classic-$_commit
+ mkdir -p "$pkgdir/usr/share/fonts/adobe-source-han-sans/"
+ install -Dm644 *.otf "$pkgdir/usr/share/fonts/adobe-source-han-sans/"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}