summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 33 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f98bdd5a8b8..fb56ed28ecbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,46 @@
# Maintainer: Emanuele 'Lele aka eldios' Calo' <xeldiosx[at]gmail[dot]com>
pkgname=adom-noteye
-epoch=1
-pkgver=2.3.8
-pkgrel=4
-pkgdesc="A roguelike game with a quest-centric, plot driven structure (+ GUI)"
+pkgver=3.0.6
+pkgrel=1
+pkgdesc="A roguelike game with a quest-centric, plot driven structure (+ GUI) - Please consider buying the game on Steam"
arch=("x86_64")
url="http://www.adom.de/"
conflicts=('adom' 'adom-restricted' 'adom-noteye')
provides=('adom')
-depends=('ncurses' 'mesa' 'sdl_image' 'sdl_net' 'sdl_mixer' 'lua51'
- 'libbsd')
-_source_url="https://repo.sshadm.in/archlinux/eldios/${arch}"
+depends=('ncurses' 'mesa' 'sdl_image' 'sdl_net' 'sdl_mixer' 'lua51' 'libbsd')
+_repo_url="https://repo.sshadm.in/archlinux/eldios"
-license=('custom: "adom"')
-source_x86_64=(${_source_url}/adom_noteye_64_2.3.8.tar.gz)
+license=('custom:adom')
+source_x86_64=(
+ "${_repo_url}/${arch}/adom_noteye_64_${pkgver}.tar.gz"
+ "${_repo_url}/common/adom.sh"
+ "${_repo_url}/common/LICENSE"
+ )
# PACKAGES
-sha256sums_x86_64=('b7bc418e872dbf290f2279d8c554c4ac19f58ae0ace2e8f3c16b1cf4fb87dc26')
+sha256sums_x86_64=(
+ '5a81afa2409af2dde461dcce89f74c89b7807504b75bd5b3796c6187768fa050'
+ 'ffd19a5088bc63dffe386b4052f29b2194ab50c5b01ca1f574cfc51225a8afa8'
+ 'd0b08609c52ab96fb1083b2b0eea3d022549c59c87b793a140f5dfa56099544b'
+ )
package() {
- # Copy entire contents of the archive to /opt
- install -d "${pkgdir}/opt"
- cp -R "${srcdir}/adom" "${pkgdir}/opt/"
- # Since the adom binary uses a relative RPATH, it's either
- # this or patching the binary
- install -d "${pkgdir}/usr/bin"
- cat>"${pkgdir}/usr/bin/adom"<<EOF
-#!/bin/sh
-cd /opt/adom && ./adom
-EOF
- chmod 755 "${pkgdir}/usr/bin/adom"
+ # Copy entire contents of the archive to /opt
+ install -d "${pkgdir}/opt"
+ cp -R "${srcdir}/adom" "${pkgdir}/opt/"
+
+ # Since the adom binary uses a relative RPATH, it's either
+ # this or patching the binary
+ install "${srcdir}/adom.sh" "${pkgdir}/opt/adom/adom.sh"
+ chmod 755 "${pkgdir}/opt/adom/adom.sh"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -s "${pkgdir}/opt/adom/adom.sh" "${pkgdir}/usr/bin/adom"
+
+ # Add the LICENSE file
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ chmod 644 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}