summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e16fdedeb478..2c823694b71e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,12 @@ pkgname=advanced-ssh-config
_name=assh
pkgver=2.11.3
_vcsref=281772c
-pkgrel=1
+pkgrel=2
pkgdesc='ssh wrapper using ProxyCommand that adds regex, aliases, gateways, includes, dynamic hostnames to SSH and ssh-config'
arch=('x86_64')
url='https://github.com/moul/assh'
license=('MIT')
+depends=('glibc')
makedepends=('go')
conflicts=('assh-git')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/moul/assh/archive/v${pkgver}.tar.gz")
@@ -22,7 +23,6 @@ build() {
-trimpath \
-buildmode=pie \
-modcacherw \
- -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
-ldflags "-X 'moul.io/assh/v2/pkg/version.Version=${pkgver}' -X 'moul.io/assh/v2/pkg/version.VcsRef=${_vcsref}'" \
-o assh \
.
@@ -36,6 +36,12 @@ check() {
package() {
cd "$_name-$pkgver"
install -Dm755 assh "${pkgdir}/usr/bin/assh"
+ install -Dm755 contrib/completion/zsh_autocomplete "${pkgdir}/usr/share/zsh/site-functions/_assh"
+ install -Dm755 contrib/completion/bash_autocomplete "${pkgdir}/usr/share/bash-completion/completions/assh"
+ for _dir_name in examples/*
+ do
+ install -Dm755 -t "${pkgdir}/usr/share/doc/advanced-ssh-config/$_dir_name" $_dir_name/*
+ done
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}