summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc7097534d74..bc74449ce5ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Murat Çileli <murat.cileli@gmail.com>
+# Contributor: Svitozar Cherepii <razotivs@gmail.com>
-pkgname="adwaita-creamy-gtk-theme"
-pkgver="3.24.8"
-pkgrel="1"
+_pkgname=adwaita-creamy
+pkgname=$_pkgname-gtk-theme
+pkgver=3.24.8
+pkgrel=2
pkgdesc="Refreshed new Adwaita theme with creamy colors and minor changes."
-arch=("x86_64")
-license=("MIT")
-url="https://github.com/murat-cileli/adwaita-creamy"
-makedepends=()
-provides=("adwaita-creamy-gtk-theme")
-source=("https://github.com/murat-cileli/adwaita-creamy/archive/$pkgver.tar.gz")
-sha256sums=("SKIP")
+url="https://github.com/murat-cileli/$_pkgname"
+arch=('any')
+license=('MIT')
+source=("https://github.com/murat-cileli/$_pkgname/archive/$pkgver.tar.gz")
+sha256sums=('1a90d1c117b4b2c5e1d877288ace89dd269caef16038c611fa50fa245f7c1279')
-package() {
- # Create directory
- mkdir -p $pkgdir/usr/share/themes/adwaita-creamy
-
- # Copy contents
- cp -r "$srcdir/adwaita-creamy-3.24.8/." "$pkgdir/usr/share/themes/adwaita-creamy"
+package() {
+ cd $_pkgname-$pkgver
+ find gtk-2.0 gtk-3.0 index.theme -type f -exec \
+ install -Dm644 {} "$pkgdir/usr/share/themes/$_pkgname/{}" \;
}