summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4e00e7d2d8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=adwm
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="Advanced dynamic window manager for X"
+arch=('i686' 'x86_64')
+url="http://github.com/bbidulock/adwm"
+license=('GPL')
+makedepends=('libxi')
+depends=('libxfixes' 'libxft' 'libxrandr' 'libxinerama' 'libxpm' 'startup-notification' 'imlib2')
+options=('!libtool')
+source=("https://github.com/bbidulock/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
+md5sums=('27c194db38a56bcf8ce9e5de230ef64e')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make V=0
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: