summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af754255720f..60f56ef9b4ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgname=aegir-hostmaster
_pkgname=${pkgname#aegir-}
pkgver=7.x_3.9
-pkgrel=1
+pkgrel=2
pkgdesc="mass Drupal hosting system - frontend"
arch=('any')
url='http://aegirproject.org'
license=('GPL')
depends=('drush>=7')
makedepends=('git')
+optdepends=('dehydrated')
source=("https://ftp.drupal.org/files/projects/$_pkgname-${pkgver//_/-}-no-core.tar.gz"
'https://ftp.drupal.org/files/projects/devel_debug_log-7.x-1.2.tar.gz'
'https://ftp.drupal.org/files/projects/devel-7.x-1.5.tar.gz'
'https://ftp.drupal.org/files/projects/drupal-7.53.tar.gz'
- 'https://github.com/lukas2511/dehydrated/archive/master.tar.gz'
'hosting_https'::'git+https://gitlab.com/aegir/hosting_https.git'
hosting_https-pkg-info.patch
hosting-hook_hosting_TASK_OBJECT_context_options-2846897-2.patch)
@@ -22,7 +22,6 @@ md5sums=('6d27c8b0de71db7c6e2b041da25c5fef'
'19561aa1a0f2e549acf5c44a8cad8e14'
'f06c912eb4edbd48fbcc2867516726a3'
'4230279ecca4f0cde652a219e10327e7'
- '62f0351d36f900884705207922d5c7d5'
'SKIP'
'da16dba10759dfa59c7d760419f3f042'
'faa872c26a49c62d841574ae10a43a20')
@@ -41,7 +40,7 @@ package() {
ln -s "/var/lib/$_pkgname/sites" "$pkgdir/usr/share/webapps/$_pkgname"
cp -a devel devel_debug_log "$pkgdir/var/lib/$_pkgname/sites/all/modules"
cp -aT hosting_https "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https"
- cp -aT dehydrated-master "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https/submodules/letsencrypt/drush/bin/letsencrypt"
+ ln -s /usr/bin/dehydrated "$pkgdir/var/lib/$_pkgname/sites/all/modules/hosting_https/submodules/letsencrypt/drush/bin/letsencrypt"
install -D <( ) "$pkgdir/var/lib/$_pkgname/sites/all/drush/drushrc.php"
install -D <( ) "$pkgdir/var/lib/$_pkgname/sites/sites.php"