summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91e893e81e37..eb15438fb9fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=aegisub-git
-pkgver=3.2.2.r305.8d3ad9ff6
+pkgver=3.2.2.r323.f6a2ac08a
pkgrel=1
pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL' 'BSD')
depends=('alsa-lib' 'boost-libs' 'fftw' 'fontconfig' 'gcc-libs' 'glibc'
'hunspell' 'icu' 'libgl' 'libpulse' 'uchardet' 'wxgtk3' 'zlib'
'libass.so' 'libffms2.so')
-makedepends=('boost' 'git' 'intltool' 'lua' 'mesa')
+makedepends=('autoconf-archive' 'boost' 'git' 'intltool' 'lua' 'mesa')
provides=('aegisub')
conflicts=('aegisub')
source=('aegisub::git+https://github.com/Aegisub/Aegisub.git'
@@ -31,17 +31,19 @@ prepare() {
sed 's/$(LIBS_BOOST) $(LIBS_ICU)/$(LIBS_BOOST) $(LIBS_ICU) -pthread/' -i tools/Makefile
+ cp -f /usr/share/aclocal/ax_boost_{chrono,filesystem,locale,regex,system,thread}.m4 m4macros/
+
./autogen.sh
- ./configure \
- --prefix='/usr' \
- --with-wx-config='/usr/bin/wx-config-gtk3' \
- --without-{portaudio,openal,oss} \
- --disable-update-checker
}
build() {
cd aegisub
+ ./configure \
+ --prefix='/usr' \
+ --with-wx-config='/usr/bin/wx-config-gtk3' \
+ --without-{portaudio,openal,oss} \
+ --disable-update-checker
make
}