summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 13 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9e84469a2ee..dda8ea9f27cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=aegisub-git
-pkgver=3.2.2.r303.3594ade71
+pkgver=3.2.2.r305.8d3ad9ff6
pkgrel=1
pkgdesc='A general-purpose subtitle editor with ASS/SSA support'
arch=('i686' 'x86_64')
url='http://www.aegisub.org'
license=('GPL' 'BSD')
-depends=('alsa-lib' 'boost-libs' 'desktop-file-utils' 'fftw' 'fontconfig'
- 'gcc-libs' 'glibc' 'hunspell' 'icu' 'libgl' 'wxgtk' 'zlib'
+depends=('alsa-lib' 'boost-libs' 'fftw' 'fontconfig' 'gcc-libs' 'glibc'
+ 'hunspell' 'icu' 'libgl' 'libpulse' 'uchardet' 'wxgtk3' 'zlib'
'libass.so' 'libffms2.so')
makedepends=('boost' 'git' 'intltool' 'lua' 'mesa')
-optdepends=('libpulse: Pulseaudio backend'
- 'openal: OpenAL backend'
- 'oss: OSS backend'
- 'portaudio: Portaudio backend')
provides=('aegisub')
conflicts=('aegisub')
source=('aegisub::git+https://github.com/Aegisub/Aegisub.git'
- 'git+https://github.com/Aegisub/assdraw.git'
- 'aegisub-icu59.1.patch::https://github.com/alucryd/Aegisub/commit/d8c69f57f7fbcea47e61381a14987856eefb5fbd.patch')
+ 'git+https://github.com/Aegisub/assdraw.git')
sha256sums=('SKIP'
- 'SKIP'
- '1e54d36f6be86d45f13b43f9823786ed7274bb2ff7e71cc0d9270de082757df3')
+ 'SKIP')
pkgver() {
cd aegisub
@@ -35,17 +29,19 @@ pkgver() {
prepare() {
cd aegisub
- patch -Np1 -i ../aegisub-icu59.1.patch
-
sed 's/$(LIBS_BOOST) $(LIBS_ICU)/$(LIBS_BOOST) $(LIBS_ICU) -pthread/' -i tools/Makefile
+
./autogen.sh
+ ./configure \
+ --prefix='/usr' \
+ --with-wx-config='/usr/bin/wx-config-gtk3' \
+ --without-{portaudio,openal,oss} \
+ --disable-update-checker
}
-build () {
+build() {
cd aegisub
- ./configure \
- --prefix='/usr'
make
}
@@ -53,9 +49,7 @@ package() {
cd aegisub
make DESTDIR="${pkgdir}" install
-
- install -dm 755 "${pkgdir}"/usr/share/licenses/aegisub-git
- install -m 644 LICENCE "${pkgdir}"/usr/share/licenses/aegisub-git/
+ install -Dm 644 LICENCE -t "${pkgdir}"/usr/share/licenses/aegisub-git/
}
# vim: ts=2 sw=2 et: