summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 0 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c0f8d7295f1..3d52532886db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,15 +13,8 @@ makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$_pkgver.tar.gz")
sha256sums=('2ef0839b0e2e79435c037662c67df675b4ebc50d7bf001079d24b0bdf1d0c098')
-prepare() {
- cd "$pkgname-$_pkgver"
- export GOPATH="$srcdir"
- go mod download
-}
-
build() {
cd "$pkgname-$_pkgver"
- export GOPATH="$srcdir"
go build \
-trimpath \
-buildmode=pie \
@@ -33,7 +26,6 @@ build() {
check() {
cd "$pkgname-$_pkgver"
- export GOPATH="$srcdir"
go test ./...
}