summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8c5088882c6..c1bc8ef61191 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=metashape
pkgname=agisoft-${_pkgname}
pkgver=1.7.4
-pkgrel=2
+pkgrel=3
pkgdesc="Photogrammetric processing of digital images and 3D spatial data generation software. Standard edition"
arch=('x86_64')
url="https://www.agisoft.com/"
@@ -106,6 +106,10 @@ package() {
# Create executables in /usr/bin
install -Dm755 "$srcdir/agisoft-metashape" "$pkgdir/usr/bin/agisoft-metashape"
+ # Set the rehostable directory and environment variables in executables for activation
+ mkdir -p "${pkgdir}/opt/agisoft/${_pkgname}/rehostable"
+ sed -i '/export LD_LIBRARY_PATH/a\\nAGISOFT_REHOST_PATH=\$dirname/rehostable\nexport AGISOFT_REHOST_PATH' "${pkgdir}/opt/agisoft/${_pkgname}/metashape.sh"
+
# Set correct permission
chmod -R g=u "$pkgdir/opt/agisoft/${_pkgname}"
chmod -R o=u "$pkgdir/opt/agisoft/${_pkgname}"