summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc8e3f1cf9f8..2b2eadd324d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=agru
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Ansible-Galaxy Requirements Updater - a fast ansible-galaxy replacement"
arch=('any')
url="https://gitlab.com/etke.cc/int/agru"
@@ -14,7 +14,12 @@ source=('vcs-repository::git+https://gitlab.com/etke.cc/int/agru.git#tag=v'$pkgv
md5sums=('SKIP')
build() {
- export GOPATH="$srcdir/go"
+ export GOPATH="$srcdir/gopath"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
cd "$srcdir/vcs-repository"