summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b13b8298f3b3..1c7b5f9b13b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
pkgname=agrum
-pkgver=0.15.0
+pkgver=1.13.2
pkgrel=1
pkgdesc="C++ Bayesian networks library"
-license=('GPL')
-arch=('i686' 'x86_64')
+license=('LGPL')
+arch=('x86_64')
url="http://agrum.gitlab.io/"
-depends=('python-pydotplus' 'python-matplotlib' 'ipython' 'unixodbc')
+depends=('python-pydot' 'python-matplotlib' 'python-six' 'ipython' 'python-ipykernel' 'python-pandas' 'python-scikit-learn' 'python-cairosvg' 'unixodbc')
makedepends=('cmake')
source=("https://gitlab.com/agrumery/aGrUM/-/archive/${pkgver}/aGrUM-${pkgver}.tar.bz2")
-sha256sums=('c6b96319e27c6ba1a58973fb75c014cc19786513574a48dc7583a7cb15426f55')
+sha256sums=('a57238e60b56c5d65dd1f7a1fcd49dfa22816621a58de48f59a8d38e23c18b89')
build() {
cd "$srcdir/aGrUM-$pkgver"
mkdir -p build && pushd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_PYTHON=ON ..
make
}