summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b743465c8f0c..2c0503dac259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: xyproto
pkgname=ags
-pkgver=3.4.1.10
+pkgver=3.4.1.14
pkgrel=1
pkgdesc='A development tool that is primarily used to create graphical adventure games'
arch=('i686' 'x86_64')
@@ -13,14 +13,20 @@ license=('Artistic2.0')
depends=('allegro4' 'dumb-a4' 'libogg' 'libtheora' 'libvorbis')
makedepends=('wxgtk')
optdepends=('wine: for installing and configuring the game')
-source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
-sha256sums=('7dd75df2131333f1b6885c89db275e0dee3f7b55d3d9c4e8afae612c94aca4e2')
+source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz"
+ 'https://github.com/adventuregamestudio/ags/commit/44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch')
+sha256sums=('4ca76b919689c68a9fda4bd56bfb63268ab5326a539ce4d681ac4ed6a908b51c'
+ '6b7092e5794ae532f79c5c6ad5f5761c217b3ec874da43537152fb8e60b20019')
prepare() {
# Copious use of auto_ptr spams the compilation output. Until they're
# replaced, just suppress the message.
sed -i 's/-Wfatal-errors/-Wfatal-errors\ -Wno-deprecated-declarations/' \
"ags-v.$pkgver/Engine/Makefile-defs.linux"
+
+ # avoid conflicts with glibc functions with the same names
+ cd "$srcdir/ags-v.${pkgver}"
+ patch -p1 < ../44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch
}
build() {