summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 22 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51d4f34e0a8f..918970a471ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,29 @@
# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Previously:
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+
# Contributor: Ainola
# Contributor: Ner0
# Contributor: quantax
-# Previously:
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
-
pkgname='ags-git'
_pkgname='ags'
-pkgver=3.4.1.1.r13.g6053e954
+pkgver=3.4.1.3.r7.gb4199b73
pkgrel=1
pkgdesc="Adventure Game Studio, a development tool that is primarily used to create graphical adventure games"
-arch=(
- 'i686'
- 'x86_64'
-)
+arch=('i686' 'x86_64')
url='http://www.adventuregamestudio.co.uk/'
-license=(
- 'custom: Artistic 2.0'
-)
-depends=(
- 'allegro'
- 'dumb'
- 'libogg'
- 'libtheora'
- 'libvorbis'
-)
-makedepends=(
- 'git'
-)
-optdepends=(
- 'wine: For non-native games'
-)
-conflicts=(
- 'ags'
-)
-source=(
- 'git+https://github.com/adventuregamestudio/ags.git'
-)
-sha256sums=(
- 'SKIP'
-)
+license=('custom: Artistic 2.0')
+depends=('allegro' 'dumb' 'libogg' 'libtheora' 'libvorbis')
+makedepends=('git')
+optdepends=('wine: For non-native games')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=('git+https://github.com/adventuregamestudio/ags.git')
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}" || exit 1
+ cd "${_pkgname}"
git describe --long --tags \
| sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
@@ -51,19 +31,19 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_pkgname}" || exit 1
+ cd "${_pkgname}"
make --directory=Engine
}
package() {
- install -Dm755 \
- "${srcdir}/${_pkgname}/Engine/${_pkgname}" \
+ cd "${_pkgname}"
+
+ install -Dm 755 \
+ "Engine/${_pkgname}" \
"${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 \
- "${srcdir}/${_pkgname}/License.txt" \
- "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 \
+ "License.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-