summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06201345eb7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="aider-chat"
+_pkgname="$pkgname"
+pkgver=0.21.0
+pkgrel=1
+pkgdesc="AI pair programming in your terminal"
+url="https://aider.chat/"
+license=("Apache2")
+arch=("any")
+provides=("aider")
+depends=("python-configargparse"
+ "python-gitpython"
+ "python-openai"
+ "python-tiktoken"
+ "python-jsonschema"
+ "python-rich"
+ "python-prompt_toolkit"
+ "python-numpy"
+ "python-scipy"
+ "python-backoff"
+ "python-pathspec"
+ "python-networkx"
+ "python-diskcache"
+ "python-grep-ast"
+ "python-yaml"
+ "python-pillow"
+ "python-diff-match-patch"
+)
+makedepends=("python-packaging" "python-build" "python-installer" "python-wheel")
+optdepends=("python-sounddevice: portaudio support"
+ "python-soundfile: portaudio support")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+b2sums=('3bbd48f85652f3209fff6204fb02cbcd4c489841c9a22a12fc9eb01d9107f9462de97cc949780abcb265dfa2126be25a4078ac1c235f4d8a32fecdc9e1d68007')
+options=("!strip")
+
+build(){
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package(){
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}