summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06a8ed08af3a..a64b741b922b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,22 @@
pkgname=airdcpp-webclient
pkgver=2.5.0
-pkgrel=0
+pkgrel=2
pkgdesc="A peer-to-peer file sharing client with web user interface"
arch=('x86_64' 'armv7h')
license=('GPL2')
url="https://github.com/airdcpp-web/${pkgname}"
depends=('miniupnpc' 'boost' 'libmaxminddb' 'leveldb' 'openssl' 'geoip' 'leveldb' 'websocketpp' 'libnatpmp' 'intel-tbb')
makedepends=('cmake' 'git' 'npm')
-source=("https://github.com/airdcpp-web/airdcpp-webclient/archive/${pkgver}.tar.gz")
-md5sums=('17e80ed002f6e956b39a2bb4154ea776')
+source=("https://github.com/airdcpp-web/airdcpp-webclient/archive/${pkgver}.tar.gz"
+ "boost.patch")
+md5sums=('17e80ed002f6e956b39a2bb4154ea776'
+ '03dd07a2bc073e5c4ca29b8f1480b2a5')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}/airdcpp-core"
+ patch -p2 --ignore-whitespace < "${srcdir}/boost.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"