summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6682fd4cc99..4111a30caf26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_basename=airwave
pkgname=${_basename}-git
pkgver=r155.8cd3507
-pkgrel=1
+pkgrel=2
pkgdesc="Airwave is a WINE-based VST bridge, that allows for the use of Windows 32- and 64-bit VST 2.4 audio plugins with Linux VST hosts"
arch=("i686" "x86_64")
license=("MIT")
@@ -19,9 +19,11 @@ fi
provides=("airwave")
conflicts=("airwave")
-source=("git+https://github.com/phantom-code/airwave.git#branch=master")
+source=("git+https://github.com/phantom-code/airwave.git#branch=master"
+ "70d8503d5ec602be0dd9f5e390f703402bdd5edc.diff")
-sha256sums=("SKIP")
+sha256sums=('SKIP'
+ '5ca16090edea771f3190a2931e4a9b25d74985724270ad0126e8c6d528031ba3')
pkgver()
{
@@ -29,6 +31,13 @@ pkgver()
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare()
+{
+ # Fix for https://bugs.winehq.org/show_bug.cgi?id=42511
+ cp /usr/include/wine/windows/winnt.h "${_basename}/src/host/"
+ patch -Np1 -i "${srcdir}/70d8503d5ec602be0dd9f5e390f703402bdd5edc.diff"
+}
+
build()
{
cd "${_basename}"