summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fe2307b8ff3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+pkgname=akira-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Native Linux App for UI and UX Design built in Vala and Gtk"
+arch=(x86_64)
+url="https://github.com/Alecaddd/Akira"
+license=(GPL3)
+makedepends=(meson)
+provides=(akira)
+source=("git+https://github.com/Alecaddd/Akira.git")
+sha256sums=(SKIP)
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ meson --prefix=/usr --buildtype=release ../Akira
+ ninja
+}
+
+check() {
+ cd build
+ ninja test
+}
+
+package() {
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}