summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db4a19c385ca..348d47b8dd1a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -140,9 +140,9 @@ build() {
msg2 "ccache was found and will be used"
fi
_logfile="${srcdir}/build.${CARCH}.$(date +%s).log"
- $prefix_cmd autobuild configure -A 64 -c ReleaseOS -- "${AL_CMAKE_CONFIG[@]}" | tee "$_logfile" 2>&1
- msg2 "Building with ${AUTOBUILD_CPU_COUNT} jobs"
- $prefix_cmd autobuild build -A64 -c ReleaseOS --no-configure | tee --append "${srcdir}/build.${CARCH}.$(date +%s).log" 2>&1
+ $prefix_cmd autobuild configure -A 64 -c ReleaseOS -- "${AL_CMAKE_CONFIG[@]}" > >(tee -a "$_logfile") 2> >(tee -a "$_logfile" >&2)
+ msg2 "Building with ${AUTOBUILD_CPU_COUNT} jobs"
+ $prefix_cmd autobuild build -A 64 -c ReleaseOS --no-configure > >(tee -a "$_logfile") 2> >(tee -a "$_logfile" >&2)
}
# template end;