summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f13e89175ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: 0xjac <aur at 0xjac dot com>
+
+pkgname=alephium-wallet-bin
+pkgdesc="The official Alephium desktop wallet."
+pkgver=0.11.1
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/alephium/alephium-wallet"
+license=('LGPL3')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source_x86_64=("https://github.com/alephium/${pkgname%-bin}/releases/download/v$pkgver/${pkgname%-bin}-linux-amd64-$pkgver.deb")
+sha256sums_x86_64=('2ffa3a3a5a7a7e6fc61f3a268176f4cc7bb0699480156ad40a16bd306d07f417')
+
+package() {
+ tar -xf data.tar.xz -C "$pkgdir"
+
+ # Move the icon to the right directory.
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/512x512/apps/"
+ mv "$pkgdir/usr/share/icons/hicolor/0x0/apps/alephium.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/alephium.png"
+ rm -r "$pkgdir/usr/share/icons/hicolor/0x0"
+}