summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f469a0055d2..e7397d11da3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Contributors: Marcin Skory, Arkham, Christoph Zeiler, Jacek Poplawski
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributors: Marcin Skory, Arkham, Christoph Zeiler, Jacek Poplawski, carstene1ns
pkgname=alephone
-_pkgdate=20150620
-pkgver=1.2.1_$_pkgdate
-pkgrel=3
+_pkgdate=20200904
+pkgver=1.3.1_$_pkgdate
+pkgrel=2
pkgdesc='A free, enhanced port of the classic FPS "Marathon 2" by Bungie Software'
arch=('i686' 'x86_64')
url="https://alephone.lhowon.org/"
license=('GPL3')
-depends=('sdl_ttf' 'sdl_image' 'sdl_net' 'smpeg' 'libmad' 'glu' 'zziplib'
+depends=('sdl2_ttf' 'sdl2_image' 'sdl2_net' 'smpeg' 'libmad' 'glu' 'zziplib'
'ffmpeg' 'boost-libs' 'curl')
optdepends=('alephone-eternalx: community-made scenario'
'alephone-evil: community-made scenario'
@@ -17,17 +17,12 @@ optdepends=('alephone-eternalx: community-made scenario'
'alephone-marathon: M1A1 data converted for AlephOne'
'alephone-marathon2: original data for Marathon 2: Durandal')
makedepends=('boost' 'mesa' 'icoutils')
-source=("https://github.com/Aleph-One-Marathon/alephone/releases/download/release-$_pkgdate/AlephOne-$_pkgdate.tar.bz2"
- "alephone-update-old-ffmpeg-enums.patch")
-sha256sums=('c0f360dfb74a6264f95d375103a74000930cf0439ffb0464f915f5379443e133'
- '2c83da1a751e677d8a980e27e3df684943f7b6b883aca5b047a11783232d4324')
+source=("https://github.com/Aleph-One-Marathon/alephone/releases/download/release-$_pkgdate/AlephOne-$_pkgdate.tar.bz2")
+sha256sums=('90227ab6ddac86af8b18eeee22dfc4b66ebe083979f36f709cb7349c6e1d938d')
prepare() {
cd AlephOne-$_pkgdate
- # backported patch to make it compile correctly
- patch -Np1 < ../alephone-update-old-ffmpeg-enums.patch
-
# convert the windows icons
cd Resources/Windows
icotool -x -w 48 alephone.ico -o "$srcdir"/alephone.png
@@ -56,3 +51,4 @@ package() {
install -Dm644 README "$pkgdir"/usr/share/doc/alephone/README
install -m644 docs/*.html "$pkgdir"/usr/share/doc/alephone
}
+